`

Coins 背包模板

 
阅读更多

 

Coins

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 218 Accepted Submission(s): 80


Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 

 

Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
 

 

Output
For each test case output the answer on a single line.
 

 

Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0
 

 

Sample Output

 

8
4
#include<stdio.h>
#include<string.h>
#define max(a,b) a>b?a:b;
int m;
int f[100010];
void zero_onepag(int w)
{
	for(int i=m;i>=w;i--)
		f[i]=max(f[i],f[i-w]+w);
}
void fullpag(int w)
{
	for(int i=w;i<=m;i++)
		f[i]=max(f[i],f[i-w]+w);
}
void allpag(int w,int n)
{
	if(w*n>m)fullpag(w);//如果东西很多,可以当成完全背包
	else//否则,当成01背包,用2分优化
	{
		int k=1;
		while(k<=n)
		{
			zero_onepag(k*w);
			n-=k;
			k*=2;
		}
		zero_onepag(n*w);
	}
}
int main()
{
	//freopen("in.txt","r",stdin);
	int n,i,totle;
	int w[110],v[110];
	while(scanf("%d%d",&n,&m),m||n)
	{
		memset(f,0,sizeof(f));
		for(i=0;i<n;i++)scanf("%d",&w[i]);
		for(i=0;i<n;i++)scanf("%d",&v[i]);
		for(i=0;i<n;i++)if(w[i]<m)allpag(w[i],v[i]);
		for(i=1,totle=0;i<=m;i++)if(f[i]==i)totle++;
		printf("%d\n",totle);
	}
	return(0);
}

 

 

 

 

 

 

 

 

 

 

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics