`

hdu 1074 Doing Homework (状态压缩DP)

阅读更多

 

连接:http://acm.hdu.edu.cn/showproblem.php?pid=1074

 

Doing Homework

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3973    Accepted Submission(s): 1581


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject's homework). 

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.
 

 

Output
For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.
 

 

Sample Input
2 3 Computer 3 3 English 20 1 Math 3 2 3 Computer 3 3 English 6 3 Math 6 3
 

 

Sample Output
2 Computer Math English 3 Computer English Math
Hint
In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the word "English" appears earlier than the word "Math", so we choose the first order. That is so-called alphabet order.

 

 

#include <cstdio>
#include <iostream>
#include <cstring>
#include <string>
using namespace std ;
#define M 1<<16

int n ;
bool mask[M] ;
struct node{
       string name ;
       int need_time ;
       int limit_time ;
}work[17] ;
struct state{
       int use_time ;
       int los_time ;
       int father ;
       int res ;
}sta[M] , tmp ;

void print( int t ){
       if( t == 0 ) return ;
       print( sta[t].father ) ;
       cout<<work[ sta[t].res ].name<<endl ;
}

int main(){
       int T ; scanf("%d" , &T ) ;
       while( T -- ){

              scanf("%d" , &n ) ;
              for( int i = 0 ; i < n ; i ++ ){
                     cin>>work[i].name>>work[i].limit_time>>work[i].need_time ;
              }
              memset( sta   ,   0   , sizeof( sta   ) ) ;
              memset( mask  , false , sizeof( mask  ) ) ;
              int m = 1<<n ;

              for( int i = 0 ; i < m ; i ++ ){
                     for( int j = 0 ; j < n ; j ++ ) if( ( i & ( 1<<j ) ) == 0 ) {
                            int new_i =  i | ( 1<<j ) ;
                            tmp.use_time = sta[i].use_time + work[j].need_time ;
                            tmp.los_time = sta[i].los_time + ( ( tmp.use_time > work[j].limit_time ) ? tmp.use_time - work[j].limit_time : 0 ) ;
                            if( mask[new_i] == false || tmp.los_time < sta[new_i].los_time ){
                                   mask[new_i] = true ;
                                   sta[new_i] = tmp ;
                                   sta[new_i].father = i ;
                                   sta[new_i].res = j ;
                            }
                     }
              }

              printf("%d\n" , sta[m-1].los_time ) ;
              print( m-1 ) ;
       }
       return 0 ;
}

 

 

 

 

1
2
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics