`

Minimum Inversion Number 线段树求逆序数

 
阅读更多

 

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 474 Accepted Submission(s): 217


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

 

Output
For each case, output the minimum inversion number on a single line.
 

 

Sample Input
10
1 3 6 9 0 8 5 7 4 2
 

 

Sample Output

 

16
#include<stdio.h>
struct Shu
{
	int zuo;
	int you;
	int date;
}shu[5000*3];
int p[5000+10];
void buildtree(int a,int b,int n=1)
{
	shu[n].zuo=a;
	shu[n].you=b;
	shu[n].date=0;
	if(a==b)return;
	int zhong=(a+b)>>1;
	buildtree(a,zhong,2*n);
	buildtree(zhong+1,b,2*n+1);
}
void addtree(int a,int n=1)
{
	shu[n].date++;
	if(shu[n].zuo==shu[n].you)return;
	int zhong=(shu[n].zuo+shu[n].you)>>1;
	if(a<=zhong)addtree(a,2*n);
	else addtree(a,2*n+1);
}
int findtree(int a,int b,int n=1)
{
	if(shu[n].zuo==a&&shu[n].you==b)return(shu[n].date);
	int zhong=(shu[n].zuo+shu[n].you)>>1;
	if(b<=zhong)return(findtree(a,b,2*n));
	else if(a>zhong)return(findtree(a,b,2*n+1));
	else return(findtree(a,zhong,2*n)+findtree(zhong+1,b,2*n+1));
}
int main()
{
//	freopen("in.txt","r",stdin);
	int min;
	int n;
	int sum;
	int i;
	while(scanf("%d",&n)!=EOF)
	{
		buildtree(0,n-1);
		sum=0;
		for(i=0;i<n;i++)
		{
			scanf("%d",&p[i]);
			sum+=findtree(p[i],n-1);
			addtree(p[i]);
		}
		min=sum;
		for(i=0;i<n-1;i++)
		{
			sum=sum+n-1-2*p[i];
			if(sum<min)min=sum;
		}
		printf("%d\n",min);
	}
	return(0);
}

 

 

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics